LAN problem

Post Reply
Brain9000
Posts: 5
Joined: Sun May 26, 2013 8:48 am

LAN problem

Post by Brain9000 » Mon May 27, 2013 6:48 am

Hi, I recently bought ParaWorld Gold on gamersgate and have not been able to play a lan game with my friend. When I click on the join game tab I get an error that says PWServer.exe has encountered a problem. I have the community patch, expansion, mappack and mirage installed. However, I've also tried to connect without any of these installed and I still get the error message. I am currently re-downloading the game from ggate because I'm thinking my file may be corrupted or something. Any advice?

User avatar
Triceratops
- Admin -
Posts: 4899
Joined: Wed Jul 25, 2007 17:16 pm
Location: Germany
Contact:

Re: LAN problem

Post by Triceratops » Mon May 27, 2013 17:32 pm

Hi Brain9000, welcome :)

Try it, this did indeed help in a lot of cases. Also make sure you follow these steps:

1) Use right mouse button - Run as admin on the setup file from Gamersgate

2) Install the game into X:\PW (X: is a hard drive of your choice)

3) After you installed the game you should make all four (.)executables in the ...Paraworld\Bin folder 'Run as admin' by changing this in their 'Properties' (Right mouse button menu)

4) Make sure you start the game with the correct shortcut (the shortcut must start ...paraworld.exe -enable boosterpack1) after you have installed the boosterpack

Are you playing the game on Vista or Win7/8?

Brain9000
Posts: 5
Joined: Sun May 26, 2013 8:48 am

Re: LAN problem

Post by Brain9000 » Tue May 28, 2013 9:39 am

Hey thanks for your help, I'm actually on xp. I tried reinstalling using run as admin but I couldn't figure out how to change the files' properties to 'run as admin'. Shortcut is fine. Still the same thing happens, I go to multiplayer, lan then click join game and it instantly brings up that error message. Rest of the game has always worked fine, at least so far... really love this game and it would suck if I couldn't play it with my friends

User avatar
AnthonyCole
- Admin -
Posts: 1994
Joined: Sat Apr 18, 2009 14:17 pm

Re: LAN problem

Post by AnthonyCole » Tue May 28, 2013 12:01 pm

PW Installation:

1. PW
2. Boosterpack 2.0

For multiplayer, dont go in online mode because that will lead to crash (servers are down). Well LAN should work, but if it doesnt:

Try connecting by direct IP. Also watch out for windows firewall warnings and allow stuff.

User avatar
Triceratops
- Admin -
Posts: 4899
Joined: Wed Jul 25, 2007 17:16 pm
Location: Germany
Contact:

Re: LAN problem

Post by Triceratops » Tue May 28, 2013 18:15 pm

Please report to us if direct ip did work

Brain9000
Posts: 5
Joined: Sun May 26, 2013 8:48 am

Re: LAN problem

Post by Brain9000 » Tue May 28, 2013 18:22 pm

Hey guys, so turns out direct IP works fine! Guess I'm just used to only using LAN for muiltiplayer games. But I'm really psyched this works, thought it would be some long arduous process like a lot of games I have trouble with. Thanks for all your help!!!

User avatar
Triceratops
- Admin -
Posts: 4899
Joined: Wed Jul 25, 2007 17:16 pm
Location: Germany
Contact:

Re: LAN problem

Post by Triceratops » Wed May 29, 2013 5:19 am

Good news, and thanks for reporting :wink:

Brain9000
Posts: 5
Joined: Sun May 26, 2013 8:48 am

Re: LAN problem

Post by Brain9000 » Mon Nov 18, 2013 6:21 am

Hey guys, so I recently tried to play with my friend and the game wasn't working. Direct ip would let him join and everything but the game wouldn't load after the countdown. My side was working fine. Not sure what the problem is...

User avatar
AnthonyCole
- Admin -
Posts: 1994
Joined: Sat Apr 18, 2009 14:17 pm

Re: LAN problem

Post by AnthonyCole » Mon Nov 18, 2013 6:51 am

You're using the same CD Key

User avatar
Triceratops
- Admin -
Posts: 4899
Joined: Wed Jul 25, 2007 17:16 pm
Location: Germany
Contact:

Re: LAN problem

Post by Triceratops » Mon Nov 18, 2013 9:23 am

If that's not the cause, please give us more information about your windows, game version(s) and what kind of network connection

Brain9000
Posts: 5
Joined: Sun May 26, 2013 8:48 am

Re: LAN problem

Post by Brain9000 » Sat Nov 23, 2013 21:06 pm

Yep it was the cd key, kind of thought that's what it was. Another question though, is there any way to save a multiplayer game? When I go to the menu the save button is greyed out.

User avatar
Triceratops
- Admin -
Posts: 4899
Joined: Wed Jul 25, 2007 17:16 pm
Location: Germany
Contact:

Re: LAN problem

Post by Triceratops » Sun Nov 24, 2013 11:06 am

If I remember correctly you can indeed save multiplayer games in Paraworld. Maybe this is restricted to Local Area networks or TCP/IP games played on the internet but I remember being able to both save and load matches. To continue an old multiplayer game you have to start the exact setup (players involved, races and maps) and the host can then, after the match has started, load the old match. This worked for me at least twice. You have to be the host of both matches by the way

Give it a try and please report us your experience

User avatar
Anakey
- Mod -
Posts: 115
Joined: Sat Jun 21, 2008 17:57 pm

Re: LAN problem

Post by Anakey » Sun Nov 24, 2013 12:20 pm

I think also you will need to edit the settings.cfg file in order to save in mp. if you scroll down there is an option that says

Code: Select all

ButtonSaveMultiplayerEnable = '0'
i think you will have to change the 0 to a 1 however i have not tested if this enables the save button or not.
Image

Thanks to Henry for making the animation

User avatar
AnthonyCole
- Admin -
Posts: 1994
Joined: Sat Apr 18, 2009 14:17 pm

Re: LAN problem

Post by AnthonyCole » Sun Nov 24, 2013 13:15 pm

Anakey is right you need that too

Post Reply

Return to “English”